re = /(?!KM)([A-Z]{2})\h(\d{3})/
str = 'BA 093, RJ 342, ES 324, KM 324, KM 123'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result