const regex = /(?!KM)([A-Z]{2})\h(\d{3})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!KM)([A-Z]{2})\\h(\\d{3})', 'g')
const str = `BA 093, RJ 342, ES 324, KM 324, KM 123`;
const subst = `$1-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);