using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^-\\]+)";
string input = @"VWR\HP 800G1\7P-TEK-32B\SP1\SYSPREP-FR-04032014.tib.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}