$re = '/([^-\\\\]+)/';
$str = 'VWR\\HP 800G1\\7P-TEK-32B\\SP1\\SYSPREP-FR-04032014.tib.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);