package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^-\\]+)`)
var str = `VWR\HP 800G1\7P-TEK-32B\SP1\SYSPREP-FR-04032014.tib.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}