package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z0-9.-])+\@([a-zA-Z0-9-]{1,63})(\.([A-Za-z]{2,6}))+`)
var str = `test@gmail also I want test@gmail.com and test@uae.gov.pk must also`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}