const regex = /([A-Za-z0-9.-])+\@([a-zA-Z0-9-]{1,63})(\.([A-Za-z]{2,6}))+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z0-9.-])+\\@([a-zA-Z0-9-]{1,63})(\\.([A-Za-z]{2,6}))+', 'g')
const str = `test@gmail also I want test@gmail.com and test@uae.gov.pk must also`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}