import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z0-9.-])+\\@([a-zA-Z0-9-]{1,63})(\\.([A-Za-z]{2,6}))+";
final String string = "test@gmail also I want test@gmail.com and test@uae.gov.pk must also";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}