using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:%)|\s[A-Z]\s|(?<=book\s)[A-Z]";
string input = @"59% J (Contains FF) book D.
Sometim100%es iam getting 59% J book D";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}