re = /\d+(?:%)|\s[A-Z]\s|(?<=book\s)[A-Z]/m
str = '59% J (Contains FF) book D.
Sometim100%es iam getting 59% J book D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end