$re = '/\d+(?:%)|\s[A-Z]\s|(?<=book\s)[A-Z]/m';
$str = '59% J (Contains FF) book D.
Sometim100%es iam getting 59% J book D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);