import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[test\\].*(?=\\<br\\s\\/\\>)";
final String string = "'This is a test to remove single lines.<br />\n"
+ "The line below has the open type bbcode (case insensitive) that is to be removed.<br />\n"
+ "The text on the same line that follows the bbcode should also be removed.\n"
+ "this text should remain[test]this text should be removed on this line only!<br />\n"
+ "the other lines should remain.<br />\n"
+ "done.<br />'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}