# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[test\].*(?=\<br\s\/\>)"
test_str = ("'This is a test to remove single lines.<br />\n"
"The line below has the open type bbcode (case insensitive) that is to be removed.<br />\n"
"The text on the same line that follows the bbcode should also be removed.\n"
"this text should remain[test]this text should be removed on this line only!<br />\n"
"the other lines should remain.<br />\n"
"done.<br />'")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.