re = /\[test\].*(?=\<br\s\/\>)/m
str = '\'This is a test to remove single lines.<br />
The line below has the open type bbcode (case insensitive) that is to be removed.<br />
The text on the same line that follows the bbcode should also be removed.
this text should remain[test]this text should be removed on this line only!<br />
the other lines should remain.<br />
done.<br />\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end