package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+)\/([1-9][0-9]{3}\/[0-1][0-9]\/[0-3][0-9])\/(.*)`)
var str = `hammaro/2015/09/06/konstsafari-runt-pa-on?refresh=true`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}