const regex = /(\S+)\/([1-9][0-9]{3}\/[0-1][0-9]\/[0-3][0-9])\/(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+)\\\/([1-9][0-9]{3}\\\/[0-1][0-9]\\\/[0-3][0-9])\\\/(.*)', '')
const str = `hammaro/2015/09/06/konstsafari-runt-pa-on?refresh=true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}