$re = '/(\S+)\/([1-9][0-9]{3}\/[0-1][0-9]\/[0-3][0-9])\/(.*)/';
$str = 'hammaro/2015/09/06/konstsafari-runt-pa-on?refresh=true';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);