$re = '/\/\*.*?\*\//s';
$str = 'int main(/* text */) {
int i = 0;
/* hello world */
return 1;
} ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);