re = /\/\*.*?\*\//
str = 'int main(/* text */) {
int i = 0;
/* hello world */
return 1;
} '
# Print the match result
str.match(re) do |match|
puts match.to_s
end