using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<|>)(?!(<span[^>]+class\s*=\s*(""|')subValue\2[^>]*>)[^<]*(<\/span>)|(<br[\/]*>))";
string input = @"<span class=""subValue""></span>
<br>
<br>
<span class='subValue'>dsa</span>
<>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}