$re = '/(<|>)(?!(<span[^>]+class\s*=\s*("|\')subValue\2[^>]*>)[^<]*(<\/span>)|(<br[\/]*>))/i';
$str = '<span class="subValue"></span>
<br>
<br>
<span class=\'subValue\'>dsa</span>
<>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);