import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<|>)(?!(<span[^>]+class\\s*=\\s*(\"|')subValue\\2[^>]*>)[^<]*(<\\/span>)|(<br[\\/]*>))";
final String string = "<span class=\"subValue\"></span>\n"
+ "<br>\n"
+ "<br>\n"
+ "<span class='subValue'>dsa</span>\n"
+ "<>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}