$re = '/(@[0-9a-zA-Z$_]+)(?=[,)])/';
$str = 'INSERT INTO tablename (id, name, email) VALUES (@id, @name, @email)
UPDATE mytable SET id = @id, name = \'myname@id\' WHERE id = 1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);