re = /(@[0-9a-zA-Z$_]+)(?=[,)])/
str = 'INSERT INTO tablename (id, name, email) VALUES (@id, @name, @email)
UPDATE mytable SET id = @id, name = \'myname@id\' WHERE id = 1;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end