using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*[^*@]*(?:\*(?!\/)[^*@]*|@(?!domain\.com)[^*@]*)*@domain\.com[^*]*(?:\*(?!\/)[^*]*)*\*\/";
string input = @"/*********************************************
*
* ... some text ....
*
* author: n@not.domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: m@domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: user@domain.com
*
*********************************************/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}