re = /\/\*[^*@]*(?:\*(?!\/)[^*@]*|@(?!domain\.com)[^*@]*)*@domain\.com[^*]*(?:\*(?!\/)[^*]*)*\*\//
str = '/*********************************************
*
* ... some text ....
*
* author: n@not.domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: m@domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: user@domain.com
*
*********************************************/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end