$re = '/\/\*[^*@]*(?:\*(?!\/)[^*@]*|@(?!domain\.com)[^*@]*)*@domain\.com[^*]*(?:\*(?!\/)[^*]*)*\*\//';
$str = '/*********************************************
*
* ... some text ....
*
* author: n@not.domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: m@domain.com
*
*********************************************/
/*********************************************
*
* ... some text ....
*
* author: user@domain.com
*
*********************************************/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);