package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*?(\d+)\D*?$`)
var str = `1
XX-1234
do-not-match-no-integers
do-not-match-1234-567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}