$re = '/^\D*?(\d+)\D*?$/m';
$str = '1
XX-1234
do-not-match-no-integers
do-not-match-1234-567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);