re = /^\D*?(\d+)\D*?$/m
str = '1
XX-1234
do-not-match-no-integers
do-not-match-1234-567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end