$re = '/\$(\{?(\w+)\}?)(?:\.\$(\{?(\w+)\}?))*?/';
$str = '$FIRSTVAR.${SECONDVAR}LITERAL
${firstvar}.${secondvar}.$thirdvar.${fourth}literal
${firstvar}.literal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);