#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)add <capacitor>(?!CAPACITOR_ONPAD_VIA)"
Local $sString = "add <capacitor>CAPACITOR_ONPAD_VIA" & @CRLF & _
"add <capacitor>sdfdsf" & @CRLF & _
"add <capacitor>something else" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")