using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[s]?:\/\/)(\S+\/)*(?!=\/$|$)([^\/]+\/)*(?=\/$|$)";
string input = @"https://www.test.ch/posts/mypost-name/
https://www.test.ch/mypost-name/
https://www.test.ch/one/two/three/mypost-name/
https://www.test.ch/one/two/three/mypost-name/noendingslash
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}