$re = '/(http[s]?:\/\/)(\S+\/)*(?!=\/$|$)([^\/]+\/)*(?=\/$|$)/m';
$str = 'https://www.test.ch/posts/mypost-name/
https://www.test.ch/mypost-name/
https://www.test.ch/one/two/three/mypost-name/
https://www.test.ch/one/two/three/mypost-name/noendingslash
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);