package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$\d+\.\d\d)`)
var str = `The total it $2.25 Would you like paper or plastic?`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}