$re = '/(\$\d+\.\d\d)/';
$str = 'The total it $2.25 Would you like paper or plastic?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);