using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=foo\b).*?\b(bar)\b.*";
string input = @"foo dum diddly bar dee
hello world bar hopping
foo how bar you
foo jingle jangle jingle";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}