re = /^(?=foo\b).*?\b(bar)\b.*/m
str = 'foo dum diddly bar dee
hello world bar hopping
foo how bar you
foo jingle jangle jingle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end