$re = '/^(?=foo\b).*?\b(bar)\b.*/m';
$str = 'foo dum diddly bar dee
hello world bar hopping
foo how bar you
foo jingle jangle jingle';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);