#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<={% highlight %}).*(?={% endhighlight %})"
Local $sString = "{% highlight %}ffasd" & @CRLF & _
"//some codefasd" & @CRLF & _
"fads" & @CRLF & _
"fdas" & @CRLF & _
"fsad" & @CRLF & _
"sda" & @CRLF & _
"asdfas" & @CRLF & _
"fads" & @CRLF & _
"fasf" & @CRLF & _
"sa" & @CRLF & _
"{% endhighlight %}" & @CRLF & _
"{% highlight %}ffasd" & @CRLF & _
"//some codefasd" & @CRLF & _
"fads" & @CRLF & _
"fdas" & @CRLF & _
"fsad" & @CRLF & _
"sda" & @CRLF & _
"asdfas" & @CRLF & _
"fads" & @CRLF & _
"fasf" & @CRLF & _
"sa" & @CRLF & _
"{% endhighlight %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")