re = /(?<={% highlight %}).*(?={% endhighlight %})/
str = '{% highlight %}ffasd
//some codefasd
fads
fdas
fsad
sda
asdfas
fads
fasf
sa
{% endhighlight %}
{% highlight %}ffasd
//some codefasd
fads
fdas
fsad
sda
asdfas
fads
fasf
sa
{% endhighlight %}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end