import re
regex = re.compile(r"(?:(?<subdomain>[a-z0-9\.\-]*)\.)?(?<domain>(?!com)[a-z0-9\-]{3,}(?=\.[a-z\.]{2,}))\.(?:(?<tld>[a-z\.]{2,})$)", flags=re.MULTILINE | re.DOTALL)
test_str = ("apple.orange.banana.clevername.co.uk\n"
"strawberry.apple.orange.banana.clevername.co.uk\n"
"tangerine.com.au\n"
"simple.com\n"
"bit.ly\n"
"something.bit.ly\n"
"clevername.com.au\n"
"hello.world.ninja\n"
"www.something.cancerresearch")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")