re = /(?:(?<subdomain>[a-z0-9\.\-]*)\.)?(?<domain>(?!com)[a-z0-9\-]{3,}(?=\.[a-z\.]{2,}))\.(?:(?<tld>[a-z\.]{2,})$)/m
str = 'apple.orange.banana.clevername.co.uk
strawberry.apple.orange.banana.clevername.co.uk
tangerine.com.au
simple.com
bit.ly
something.bit.ly
clevername.com.au
hello.world.ninja
www.something.cancerresearch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end