#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "this[^\d]+\K\d+"
Local $sString = "188282 this is an example of a number 12345 and 54321" & @CRLF & _
"188282 this is an example of a number 1234556" & @CRLF & _
"this is an example of a number 1234556" & @CRLF & _
"187293 this is another example of a number 74893 and 83978"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")