import re
regex = re.compile(r"this[^\d]+\K\d+")
test_str = ("188282 this is an example of a number 12345 and 54321\n"
"188282 this is an example of a number 1234556\n"
"this is an example of a number 1234556\n"
"187293 this is another example of a number 74893 and 83978")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")