using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"this[^\d]+\K\d+";
string input = @"188282 this is an example of a number 12345 and 54321
188282 this is an example of a number 1234556
this is an example of a number 1234556
187293 this is another example of a number 74893 and 83978";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}