#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-[dn] (?!.*?-[dn]).*$"
Local $sString = "hello world blah -d blah vlaah -n blah vlahh" & @CRLF & _
"hello world blah -n blah vlahh -d blah vlaah" & @CRLF & _
"hello world blah -d blaaah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")