import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-[dn] (?!.*?-[dn]).*$";
final String string = "hello world blah -d blah vlaah -n blah vlahh\n"
+ "hello world blah -n blah vlahh -d blah vlaah\n"
+ "hello world blah -d blaaah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}