re = /-[dn] (?!.*?-[dn]).*$/m
str = 'hello world blah -d blah vlaah -n blah vlahh
hello world blah -n blah vlahh -d blah vlaah
hello world blah -d blaaah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end