const regex = /^\/teacher\/(?<id>\d+)\/(?<method>(?:list)|(?:file)|(?:info))(?:(?<=list)$|(?:(?:(?<=file)|(?<=info))\/(?<name>.+$)))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/teacher\\\/(?<id>\\d+)\\\/(?<method>(?:list)|(?:file)|(?:info))(?:(?<=list)$|(?:(?:(?<=file)|(?<=info))\\\/(?<name>.+$)))', '')
const str = `/teacher/1/info/a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}